Refine your search

1 vulnerability found for Opensea by Unknown

CVE-2022-1228 (GCVE-0-2022-1228)
Vulnerability from cvelistv5
Published
2022-04-25 15:51
Modified
2024-08-02 23:55
Severity ?
CWE
  • CWE-79 - Cross-site Scripting (XSS)
Summary
The Opensea WordPress plugin before 1.0.3 does not sanitize and escape some of its settings, like its "Referer address" field, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Impacted products
Vendor Product Version
Unknown Opensea Version: 1.0.3   < 1.0.3
Create a notification for this product.
Show details on NVD website


{
  "containers": {
    "adp": [
      {
        "providerMetadata": {
          "dateUpdated": "2024-08-02T23:55:24.424Z",
          "orgId": "af854a3a-2127-422b-91ae-364da2661108",
          "shortName": "CVE"
        },
        "references": [
          {
            "tags": [
              "x_refsource_MISC",
              "x_transferred"
            ],
            "url": "https://wpscan.com/vulnerability/ef6830c0-e933-4e62-8321-011d91f9cfea"
          }
        ],
        "title": "CVE Program Container"
      }
    ],
    "cna": {
      "affected": [
        {
          "product": "Opensea",
          "vendor": "Unknown",
          "versions": [
            {
              "lessThan": "1.0.3",
              "status": "affected",
              "version": "1.0.3",
              "versionType": "custom"
            }
          ]
        }
      ],
      "credits": [
        {
          "lang": "en",
          "value": "Mika"
        }
      ],
      "descriptions": [
        {
          "lang": "en",
          "value": "The Opensea WordPress plugin before 1.0.3 does not sanitize and escape some of its settings, like its \"Referer address\" field, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed."
        }
      ],
      "problemTypes": [
        {
          "descriptions": [
            {
              "cweId": "CWE-79",
              "description": "CWE-79 Cross-site Scripting (XSS)",
              "lang": "en",
              "type": "CWE"
            }
          ]
        }
      ],
      "providerMetadata": {
        "dateUpdated": "2022-04-25T15:51:23.000Z",
        "orgId": "1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81",
        "shortName": "WPScan"
      },
      "references": [
        {
          "tags": [
            "x_refsource_MISC"
          ],
          "url": "https://wpscan.com/vulnerability/ef6830c0-e933-4e62-8321-011d91f9cfea"
        }
      ],
      "source": {
        "discovery": "EXTERNAL"
      },
      "title": "Opensea \u003c 1.0.3 - Admin+ Stored XSS",
      "x_generator": "WPScan CVE Generator",
      "x_legacyV4Record": {
        "CVE_data_meta": {
          "ASSIGNER": "contact@wpscan.com",
          "ID": "CVE-2022-1228",
          "STATE": "PUBLIC",
          "TITLE": "Opensea \u003c 1.0.3 - Admin+ Stored XSS"
        },
        "affects": {
          "vendor": {
            "vendor_data": [
              {
                "product": {
                  "product_data": [
                    {
                      "product_name": "Opensea",
                      "version": {
                        "version_data": [
                          {
                            "version_affected": "\u003c",
                            "version_name": "1.0.3",
                            "version_value": "1.0.3"
                          }
                        ]
                      }
                    }
                  ]
                },
                "vendor_name": "Unknown"
              }
            ]
          }
        },
        "credit": [
          {
            "lang": "eng",
            "value": "Mika"
          }
        ],
        "data_format": "MITRE",
        "data_type": "CVE",
        "data_version": "4.0",
        "description": {
          "description_data": [
            {
              "lang": "eng",
              "value": "The Opensea WordPress plugin before 1.0.3 does not sanitize and escape some of its settings, like its \"Referer address\" field, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed."
            }
          ]
        },
        "generator": "WPScan CVE Generator",
        "problemtype": {
          "problemtype_data": [
            {
              "description": [
                {
                  "lang": "eng",
                  "value": "CWE-79 Cross-site Scripting (XSS)"
                }
              ]
            }
          ]
        },
        "references": {
          "reference_data": [
            {
              "name": "https://wpscan.com/vulnerability/ef6830c0-e933-4e62-8321-011d91f9cfea",
              "refsource": "MISC",
              "url": "https://wpscan.com/vulnerability/ef6830c0-e933-4e62-8321-011d91f9cfea"
            }
          ]
        },
        "source": {
          "discovery": "EXTERNAL"
        }
      }
    }
  },
  "cveMetadata": {
    "assignerOrgId": "1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81",
    "assignerShortName": "WPScan",
    "cveId": "CVE-2022-1228",
    "datePublished": "2022-04-25T15:51:23.000Z",
    "dateReserved": "2022-04-04T00:00:00.000Z",
    "dateUpdated": "2024-08-02T23:55:24.424Z",
    "state": "PUBLISHED"
  },
  "dataType": "CVE_RECORD",
  "dataVersion": "5.1"
}